Można by rzec, że to tylko dwa słowa, a znaczą tak wiele. Xposed Framework to coś, co doskonale znają miłośnicy modyfikacji urządzeń pracujących pod kontrolą Androida. W jednym z Galaktycznych Poradników Bartek przybliżył Wam niektóre z możliwości modułów Xposed. Niestety wraz z pojawieniem się na rynku Androida 5.0 Lollipop, wiele osób poczuło ogromne rozczarowanie, ponieważ najnowsza wersja systemu uniemożliwia korzystanie z Xposed. Już niebawem się to zmieni!

Powód takiego stanu rzeczy jest prosty – Android w wersji 5.0 działa w oparciu o ART, a nie jak to było do tej pory o Dalvik. Natomiast Xposed Framework został stworzony z myślą o współpracy z tym drugim. O ile KitKat dawał użytkownikowi możliwość wyboru tzw. runtime, tak w Lollipopie dalvik zniknął całkowicie. Dlatego też osoby, które zdecydowały się zaktualizować swoje urządzenia do najnowszej wersji systemu mobilnego od Google, straciły możliwość korzystania z dobrodziejstw najrozmaitszych modułów Xposed.

To, co dotąd wydawało się niemożliwe, dziś wydaje się już tylko kwestią czasu. Jeden z developerów odpowiedzialnych za stworzenie Framework’a, rovo89 opublikował dziś wiadomość, która ucieszyła entuzjastów modyfikacji Androida ze wszystkich zakątków świata. W wątku na forum xda-developers dotyczącym Xposed dla Androida 5.0 poinformował o postępie swoich prac.

Xposed Framework dla Androida 5.0 Lollipop
Xposed Framework dla Androida Lollipop / fot. forum.xda-developers.com

Wiadomo, że na efekt końcowy musimy jeszcze poczekać, ale są już wyraźne postępy. Na powyższym zdjęciu widać Xposed uruchomiony na Nexusie 5 pracującym na Androidzie Lollipop. Co najważniejsze, jak napisał autor, już wkrótce doczekamy się opublikowania efektów tych prac. Oczywiście żadne daty nie zostały na razie podane, dlatego musimy uzbroić się w cierpliwość i trzymać kciuki za developerów. Ja jako zagorzała miłośniczka „customów” i wszelkich modyfikacji, ze zniecierpliwieniem czekam aż będę mogła przetestować nowy Xposed na swoim urządzeniu.

źródło: forum.xda-developers.com